All systems operational

We have seen issues with When I Work time punches, and our team is investigating now.

Resolved
Partial outage
Started 4 months ago Lasted 6 days

Affected

Third party integrations
When I Work integration
Updates
  • Resolved
    Resolved

    We have resolved all issues with the When I Work integration. We have also sent an email to all affected stores with employee time punches for the last week. If any time punches did not go through automatically, you can reference the email to adjust as needed within When I Work. We apologize for the inconvenience, and please let us know if you have any further issues.

  • Investigating
    Investigating
    We are currently investigating this incident.